Chrome, Edge, IE, Firefox и Safari откажутся от TLS 1.0 и TLS 1.1 до 2020 года - Новости и Обзоры
интернет-защита
все антивирусы в одном приложении

Chrome, Edge, IE, Firefox и Safari откажутся от TLS 1.0 и TLS 1.1 до 2020 года

Представители Apple, Google, Microsoft и Mozilla анонсировали, что их браузеры (Chrome, Edge, IE, Firefox и Safari) прекратят поддерживать Transport Layer Security (TLS) версий 1.0 и 1.1 уже в первой половине 2020 года.

Стоит сказать, что этим версиям протокола защиты транспортного уровня по скоро исполнится по 20 и 12 лет, соответственно.

«Два десятилетия – это долгий срок для технологии безопасности, которая не претерпевала изменений. И хотя нам неизвестно о каких-либо значительных уязвимостях в наших актуальных имплементациях TLS 1.0 и TLS 1.1, переход на более новые версии позволит сделать Веб более безопасным для всех», — пишут в официальном блоге разработчики Microsoft.

Дело в том, что недавно вопрос о признании TLS 1.0 и TLS 1.1 устаревшими подняли в Инженерном совете интернета (Internet Engineering Task Force, IETF), открытой международной организации, объединяющей проектировщиков, ученых, сетевых операторов, провайдеров и занимающейся развитием протоколов и архитектуры интернета.

Нужно заметить, что Chrome, Edge, IE, Firefox и Safari уже сейчас поддерживают TLS 1.2 (вышедший 10 лет назад), а также все браузеры скоро должны реализовать поддержку недавно одобренной версии TLS 1.3. Если точнее, то в Chrome и Firefox поддержка TLS 1.3 уже появилась, а разработчики Apple и Microsoft еще работают над этим.

В своем заявлении разработчики Microsoft приводят данные SSL Labs, согласно которым 94% интернета уже работает с TLS 1.2. Также в компании пишут, что менее одного процента соединений, проходящих ежедневно через Microsoft Edge, используют TLS 1.0 или 1.1. Похожую статистику приводят инженеры Apple и Google. По их словам, Safari и Chrome обращаются к TLS 1.0 и 1.1 лишь в 0,36% и 0,5% случаев, соответственно.

Кроме того, к технологическим гигантам присоединились и разработчики Gitlab, которые так же анонсировали, что прекращают поддержку TLS 1.0 и TLS 1.1 для сайта и своей API-инфраструктуры. Однако в Gitlab не планируют затягивать с этим до 2020 года, и изменения вступят в силу уже в конце года текущего.

Сообщество Вконткте
обзоры антивирусов и программ безопасности
Комментарии и отзывы
Добавляя комментарий, ознакомьтесь с Правилами сообщества
Система Orphus